DTC Troubleshooting: 9-6

DTC 9-6:  Faulty Left Front Sensor

Special Tools Required
SRS inflator simulator (  07SAZ-TB4011A)
 

SRS simulator lead H (  07YAZ-S3A0100)
 


1.Erase the DTC memory.

2.Turn the ignition switch ON (II), and check that the SRS indicator comes on for about 6 seconds and then goes off.

Does the SRS indicator stay on?


YES - Go to 3.


NO - Intermittent failure, system is OK at this time. Go to Troubleshooting Intermittent Failures.


3.Turn the ignition switch OFF. Check the connections between U1o connector and the SRS unit, and between the engine compartment wire harness 2P connector and the left front sensor.

Are the connections OK?


YES - Go to 4.


NO - Repair the poor connections and retest. If DTC 9-6 still present, replace the left front sensor and retest. If the DTC is still preset, replace the  SRS unit.n


4.Disconnect the battery negative cable, and wait for 3 minutes.

5.Disconnect the D1o connector from the D1i connector (1).

 

6.Disconnect the P1o connector from the P1i connector (1).

 

7.Disconnect the TL1o and TR1o connectors from the TL1i and TR1i connectors (1).

 

8.Disconnect the FSL1i connector (1) from the left front sensor.

 

9.Disconnect the U1o connector (1) from the SRS unit (A).

 

10.Check resistance between the No. 10 and No. 11 terminals of U1o connector. There should be 1 MW or more.

 

Is the resistance as specified?


YES - Go to 11.


NO - Short in the engine compartment wire harness or dashboard wire harness B; replace the faulty harness.n


11.Reconnect the battery negative cable.

12.Turn the ignition switch ON (II).

13.Check the voltage between the No. 10 terminal of U1o connector and the body ground. There should be 1 V or less.

 

Is the voltage as specified?


YES - Go to 14.


NO - Short to power in the engine compartment wire harness or dashboard wire harness B; replace the faulty harness.n

14.Turn the ignition switch OFF.

15.Connect the special tool (jumper connector) to the FSL1i connector (1).

 

16.Check resistance between the No. 10 and No. 11 terminals of U1o connector. There should be 1 W or less.

 

Is the resistance as specified?


YES - Faulty left front sensor or  SRS unit. Replace the left front sensor; if the problem is still present, replace the SRS unit.n


NO - Faulty engine compartment wire harness or dashboard wire harness B; replace the faulty harness.n